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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.

4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

http://www.ansys.com/Support/


Table of Contents
Table of Contents Contents-1

1 - Introduction 1-1

Set 3D UI Options 1-2

2 - Create a Project and Build the Model 2-1

Create a Project 2-1

Define Options 2-1

Build the Model 2-1

Resize the Cabinet 2-1

Define a Variable and Create the Fan 2-2

Define a Variable 2-2

Create the Fan Component 2-2

Create the Grille 2-4

Create the Wall 2-4

Create Solid Blocks 2-5

Create Block Geometry 2-5

Create Duplicates of the Block 2-6

Assign Block Boundary Conditions 2-6

Assign Conducting Plate Boundary Conditions 2-6

Create Network Blocks 2-7

Create Block Geometry 2-7

Assign Network Boundary Condition 2-7

Create Duplicates of the Block and Network 2-8

Create a Hollow Block 2-9

Create a Local Coordinate System 2-9

Create a Hollow Block 2-9

Create a Heat Sink 2-10

Create the Heat Sink 2-10

Create the Pin Bond Plates 2-11

Getting Started with Icepak®: Optimization of Fan Location

Contents-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Optimization of Fan Location

View the Design List 2-15

3 - Assign Mesh Regions 3-1

Create the RF Amplifier Mesh Region 3-1

Create a Non-Model Box 3-1

Assign a Mesh Region to the Non-Model Box 3-1

Assign a Mesh Region to the Fan Component 3-1

4 - Generate and Display Mesh 4-1

Generate the Mesh 4-1

Display the Mesh 4-1

Check Mesh Quality 4-2

5 - Define the Simulation Settings 5-1

Define the Design Settings 5-1

Add a Solution Setup 5-1

6 - Create Monitor Points 6-1

Create a Thermal Monitor 6-1

Create a Flow Monitor 6-1

7 - Set Up and Run the Parametric Trials 7-1

Set Up the Parametric Trials 7-1

Run the Parametric Trials 7-2

8 - Post-process the Results 8-1

Create a Plane Cut 8-1

Create a Plane Cut 8-1

Create Object Field Overlays 8-2

Plot Temperature on the Wall and Blocks 8-2

Switch the Design Variation 8-3

Create a Fields Summary Report 8-4

9 - Summary 9-1

Contents-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It demonstrates and optimization features with the help of a small system-level model.

In this tutorial you will learn how to:

l Use network blocks as one way of modeling packages.
l Specify a contact resistance using side specifications of a block object.
l Define a variable as a parameter and solve the parametric trials to optimize your model for
maximum performance.

l Specify fan curves and dynamically update them.
l Use local coordinate systems.
l Generate a fields summary report for multiple parametric solutions.

This chapter contains the following topic:

l "Sample Project - The System-Level Model" below

Sample Project - The System-Level Model
The system-level model consists of a series of IC chips on a PCB. A fan is used for forced con-
vection cooling of the power dissipating devices. A bonded fin extruded heat sink with eight
0.008 m thick fins is attached to the IC chips. The fan flow rate is defined by a nonlinear fan
curve. The system also consists of a perforated thin grille. A study is carried out for the optimum
location of the fan by using the parameterization feature in Icepak.

Getting Started with Icepak®: Optimization of Fan Location
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Figure 1-1: System-Level Model

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:
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3. ClickOK.

Introduction 1-3

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 1-4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: Optimization of Fan Location



2 - Create a Project and Build the Model
After launching the Ansys Electronics Desktop, create a project, insert an Icepak design, and
build the model.

Create a Project
1. On the Desktop ribbon, click New.
2. From the Projectmenu, select Insert Icepak Design.
3. In the Project Manager, right-click on the project name and select Rename.
4. Rename the project "Parameterize_Fan."
5. From the Filemenu, select Save.
6. Save the project in your working directory.

Define Options
The model in this project primarily uses meters as the length unit. Also, Icepak provides two
methods of presenting the user interface when creating native 3D components and boundary
conditions: a wizard or a tabbed interface. The instructions in this guide are written for the tabbed
interface. In the options, define the default length unit and set the component and boundary con-
dition interface option.

1. From theModelermenu, select Units.
2. In the Set Modeler Units and Max Extent dialog box, select meter from the Select units

drop-down and clickOK.
3. From the Toolsmenu, selectOptions > General Options.
4. Expand Icepak and click Thermal.
5. Disable Use Wizards for data input when creating new boundaries.
6. ClickOK.

Build the Model
Resize the Cabinet

1. In the History tree, expandModel > Solids > air > Region and select CreateRegion.
2. In the Properties window, define the following parameters:

l +X Padding Type: Absolute Position
l +X Padding Data: 0.4 meter
l -X Padding Type: Absolute Position

Getting Started with Icepak®: Optimization of Fan Location
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l -X Padding Data: 0 meter
l +Y Padding Type: Absolute Position
l +Y Padding Data: 0.13 meter
l -Y Padding Type: Absolute Position
l -Y Padding Data: 0 meter
l +Z Padding Type: Absolute Position
l +Z Padding Data:0.25 meter
l -Z Padding Type: Absolute Position
l -Z Padding Data: 0 meter

Define a Variable and Create the Fan
First define a variable to be used for the location of the fan and then create the fan component.

Define a Variable
1. From the Projectmenu, select Project Variables.
2. In the Properties dialog box, click Add.
3. In the Add Property dialog box, define the following parameters:

l Name: $zc
l Unit Type: Length
l Units: meter
l Value: 0.1

4. ClickOK to close the Add Property dialog box.
5. ClickOK to close the Properties dialog box.

Create the Fan Component
1. In the Project Manager, right-click 3D Components and select Create > Fan.
2. In the Fan Component dialog boxGeometry tab, define the following parameters:

l Cross-section: YZ
l Radius: 0.05 meter
l Hub Radius: 0.02 meter

3. On the Properties tab, retain the Flow Type selection of Curve and click Edit Curve.
4. In the Edit Dataset dialog box, enter the values displayed in the following image.

Create a Project and Build the Model 2-2
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5. ClickOK to close the Edit Dataset dialog box.
6. Under Swirl, select RPM and enter 4000 for RPM and 2000 forOperating RPM.
7. ClickOK.
8. In the History tree, expandModel > Fan1.
9. Right-click Fan1_1 and select Edit > Arrange > Move.
10. Press F4 to display theMove dialog box.
11. In theMove dialog box, enter 0 ,0.07 ,0.1 for theMove Vector Value.
12. Replace 0.1 with the variable $zc.
13. Click OK.

Create a Project and Build the Model 2-3
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Note: To change the color of the fan geometry, expandModel > Fan1 > Fan1_1 >
Sheets > Unassigned and select both Fan1_Hub and Fan1_Passage. In the Prop-
erties window, click the current color in the Value cell and select the new color in the in
the Color window.

Create the Grille
1. Press F to enter face selection mode.
2. In the 3D Modeler window, select the cabinet face opposite the fan.

3. Right-click and select Assign Thermal > Grille.
4. In theGrille Thermal Model dialog box under Flow Specification, enter a Free Area

Ratio of 0.5.
5. Click OK.

Create the Wall
Create a wall on the Ymax face of the amplifier housing to cover the Xmin side of the enclosure.

1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0 ,0 ,0 meter
l XSize: 0.4 meter
l YSize: 0.01 meter
l ZSize: 0.25 meter

Create a Project and Build the Model 2-4
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3. On the Attribute tab, define the following parameters:
l Name: wall_1
l Material: FR-4

4. ClickOK.

5. In the History tree, expandModel > Solids > FR-4.
6. Right-clickwall_1 and select Select > All Faces.
7. Right-click in the 3D Modeler window and select Assign Thermal > Wall > Stationary.
8. In the Stationary Wall Thermal Model dialog box, define the following parameters:

l Name: wall_1
l Wall Thickness: 0.001 meter
l Solid Material: FR-4
l External Condition: Heat Flux
l Heat Transfer Coefficient: 20 irrad_W_per_m2

9. ClickOK.

Create Solid Blocks
Create block geometry and duplicate it to create four solid blocks that dissipate 5 W each and
have a contact resistance of 0.005 C/W.

Create Block Geometry
1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0.05 ,0.01 ,0.1 meter
l XSize: 0.05 meter

Create a Project and Build the Model 2-5
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l YSize: 0.02 meter
l ZSize: 0.05 meter

3. On the Attribute tab, define the following parameters:
l Name: block_1
l Material: Al_Extruded
l Color: Select a unique color

4. ClickOK.

Create Duplicates of the Block
1. In the History tree, expandModel > Solids > Al-Extruded.
2. Right-click block_1 and select Edit > Duplicate > Along Line.
3. Enter 0.08 ,0 ,0 for the Vector to copy the devices in the X direction.
4. In the DuplicateAlongLine dialog box, enter 4 for Total Number.
5. Click OK.

Assign Block Boundary Conditions
1. In the History tree, right-click block_1 and select Assign Thermal > Block.
2. In the Block Thermal Model dialog box, define a Total Power of 5 W.
3. Click OK.
4. Repeat steps 1 through 3 for block1_1, block,1_2, and block1_3.

Assign Conducting Plate Boundary Conditions
1. In the 3D Modeler window, select the min Y face of block_1.

2. Right-click and select Assign Thermal > Plate > Conducting.
3. In the Conducting Plate Thermal Model dialog box, define the following parameters:

Create a Project and Build the Model 2-6
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l Thermal Specification: Thermal Resistance
l Thermal Resistance: 0.005 cel_per_w

4. Repeat steps 1 through 4 for the min Y face of block1_1, block,1_2, and block1_3.

Create Network Blocks
Create block geometry and duplicate it to create four network blocks to model integrated circuit
chips.

Create Block Geometry
1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0.05 ,0.01 ,0.18 meter
l XSize: 0.05 meter
l YSize: 0.02 meter
l ZSize: 0.05 meter

3. On the Attribute tab, define the following parameters:
l Name: block_2
l Material: Al_Extruded
l Solve Inside: Disabled
l Color: Select a unique color

4. ClickOK.

Assign Network Boundary Condition
1. Right-click block_2 and select Select > All Faces.
2. Right-click in the 3D Modeler window and select Assign Thermal > Network.
3. In the Network Thermal Model dialog box, create a network with the following:

l Face Nodes: 6
l Internal Nodes: 1

Create a Project and Build the Model 2-7
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l Resistance Links: 6

l

4. For the internal node, define the following parameters:
l Power: 10 W
l Mass:0.001 kg
l Specific Heat: 1000 J_per_Kelkg

5. For the resistance links, define a Thermal Resistance of 5 cel_per_w.
6. ClickOK.

Create Duplicates of the Block and Network
1. In the History tree, expandModel > Solids > Al-Extruded.
2. Right-click block_2 and select Edit > Duplicate > Along Line.
3. Enter 0.08 ,0 ,0 for the Vector to copy the devices in the X direction.
4. In the DuplicateAlongLine dialog box, enter 4 for Total Number.
5. Change the Unit tometer.
6. Click OK. The duplicate geometry is created and boundary conditions assigned.
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Create a Hollow Block
To cut out a section of the cabinet from the computational domain, create a hollow block. This
represents a region that does not directly affect heat transfer via solid conduction but that does,
however, alter the flow patterns surrounding this region. To demonstrate the creation of a local
coordinate system, create a local coordinate system and use it to position the hollow block.

Create a Local Coordinate System
1. From theModelermenu, select Coordinate System > Create > Relative CS>Offset.
2. Press F4 to display the Set Origin dialog box.
3. Enter 0.1 meter for the X offset.

4. ClickOK.
5. In the History tree, note that the RelativeCS1 coordinate system is now the working

coordinate system, denoted by the letter W.

Create a Hollow Block
With the local coordinate system set as the working coordinate system, create a hollow block.

1. From the Drawmenu, select Box.

Note: If the CreateBox dialog box is displayed, press F3 to enter point drawing
mode.

Create a Project and Build the Model 2-9
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2. In the CreateBox dialog box, define the following size parameters and units:
l Position: 0 ,0.01 ,0 meter
l XSize: 0.15 meter
l YSize: 0.09 meter
l ZSize: 0.07 meter

3. On the Attribute tab, define the following parameters:
l Name: block_3
l Material: Al_Extruded
l Solve Inside: Disabled
l Transparent: 1

4. ClickOK.

Create a Heat Sink
Create a detailed heat sink and bond plates. The heat sink base acts as a spreader for all the
IC chips.

Create the Heat Sink
1. In the History tree, clickGlobal to set the global coordinate system as the working coordin-

ate system.
2. In the Project Manager, right-click 3D Components and select Create > Heatsink.
3. In the Heatsink Component dialog boxGeometry tab, define the following parameters:

l Plane: ZX
l Overall height: 0.06 meter
l Base Length: 0.13 meter
l Base Width: 0.29 meter
l Base Height: 0.01 meter
l Fin Type: Extruded
l Fin Flow Direction: X
l Fin Count: 8
l Fin Thickness: 0.008 meter

4. In the Heatsink Component dialog box Properties tab, define the Heatsink Base Solid
Material as Cu-Pure.

5. ClickOK.
6. In the History tree, expand Heatsink1.
7. Right-click Heatsink1_1 and select Edit > Arrange > Move.
8. In theMove dialog box, enter aMove Vector of 0.195 ,0.03 ,0.165 meter.

Create a Project and Build the Model 2-10
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9. Click OK.

Create the Pin Bond Plates
Draw rectangle geometry for each pin bond plate. The plates are the same dimensions as the
bottom pin face.

1. In the History tree, expandModel > Heatsink1 > Heatsink1_1 > Solids > Al-Extruded.
2. Use the Shift key to select all Heatsink1 pin geometry simultaneously.
3. In the 3D Modeler window, right-click and select View > Show Only Selection.
4. On the View ribbon, select Dimetric from theOrient drop-down.
5. Click Fit All to zoom in on the heatsink pin geometry.
6. From the Drawmenu, select Rectangle.

Note: If the CreateBox dialog box is displayed, press F4.

7. Right-click in the 3D Modeler window and set the following options:
l Movement Mode: 3D
l Grid Plane: XZ

Create a Project and Build the Model 2-11
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8. Click on the upper left corner of the top pin as displayed in the following image.

Create a Project and Build the Model 2-12

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Optimization of Fan Location

9. Then click on the lower right corner of the same pin as displayed in the following image.
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10. Repeat steps 6 through 9 for the remaining seven pins.

11. In the History tree, expandModel > Sheets > Unassigned.
12. Right-click Unassigned and select Select All.
13. In the 3D Modeler window, right-click and select Assign Thermal > Plate > Conducting.
14. In the Conducting Plate Thermal Model dialog box, define the following parameters:

l Thickness: 0.0002 meter
l Shell Conduction: Enabled
l Side specification: Low side and High side enabled

15. ClickOK.
16. In the 3D Modeler window, right-click and select View > Show All.
17. On the View ribbon, click Fit All.
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View the Design List
Display the Design List to review the model geometry and thermal boundary condition assign-
ments.

1. From the Icepakmenu, select List.
2. On theModel tab, review the model geometry.
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3. Click the Thermal tab and review the boundary condition assignments.
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3 - Assign Mesh Regions
To generate a finer mesh in the fan and enclosure, create two mesh regions. The first mesh
region consists of the RF amplifier; the second consists only of the fan.

Create the RF Amplifier Mesh Region
The RF amplifier consists of the blocks and heatsink. First create a non-model box to encom-
pass all of the components.

Create a Non-Model Box
Non-model geometry do not have thermal or material assignments and can be used to assign
mesh regions to custom shapes.

1. From the Drawmenu, select Box.
2. Press F4 to display the CreateBox dialog box.
3. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0.045 ,0.005 ,0.095 meter
l XSize: 0.31 meter
l YSize: 0.09 meter
l ZSize: 0.14 meter

4. On the Attribute tab, define the following parameters:
l Name: blocks_heatsink_meshregion
l Model: Disabled
l Transparent: 1

5. Click OK.

Assign a Mesh Region to the Non-Model Box
1. In the History tree, expandModel > Solids > Non-Model.
2. Right-click blocks_heatsink_meshregion and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog box, enter Blocks_Heatsink for the Name.
5. Under Auto Mesh Setting, move the slider bar to the Fine/Large position.
6. ClickOK.

Assign a Mesh Region to the Fan Component
1. In the Project Manager under 3D Components, select Fan1_1.
2. In the 3D Modeler window, right-click and select Assign Mesh Region.
3. On the SubRegion dialog box, select Pad individual directions for Padding Data.
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4. For each Direction, select Absolute Offset from the Padding type drop-down and enter
the following values.

l +X: 0.005 meter
l -X: 0 meter
l +Y: 0.002 meter
l -Y: 0.002 meter
l +Z: 0.002 meter
l -Z: 0.002 meter

5. In theMesh Region dialog box, enter Fan for the Name.
6. Under Auto Mesh Setting, move the slider bar to the Fine/Large position.
7. ClickOK.
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4 - Generate and Display Mesh
After creating the mesh regions, generate and display the mesh. Also, check the mesh quality by
examining the face alignment.

Generate the Mesh
1. In the Project Manager, right-clickMesh and selectGenerate Mesh. TheMesh Visu-

alization dialog box automatically appears after the meshing process completes.
2. In theMesh Visualization dialog box underMesh display on, enable Show and select

Geometry/Boundary selection.
3. In the History tree, right-clickModel and select Select All.
4. On the View ribbon, select Front from theOrient drop-down list.

Display the Mesh
1. In theMesh Visualization dialog box underMesh display on, enable Show and select

Geometry/Boundary selection.
2. In the History tree, right-clickModel and select Select All.
3. ExpandModel > Solids > Non Model.
4. Use the Ctrl key to deselect blocks_heatsink_meshregion.
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5. Examine the mesh by taking plane cuts in all directions under theMesh Display tab.

Check Mesh Quality
1. In theMesh Visualization dialog box, click theQuality tab and examine face alignment.

Note: Due to differences among different machines, the numbers may not be
exactly the same as those in the following image.
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Note: This graph displays the cell count versus face alignment. Adjacent mesh
faces that are not aligned can result in long, narrow elements. A value of 1 indic-
ates perfect alignment. Values less than 0.15 indicate a severely distorted mesh.

2. Click Close.
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5 - Define the Simulation Settings
Define the Design Settings

1. From the Icepakmenu, select Design Settings.
2. On the Icepak Design Settings dialog boxGravity tab, selectGlobal::Y and Negative to

define the force of gravity in the negative Y direction based on the Global coordinate sys-
tem.

3. ClickOK.

Add a Solution Setup
1. In the Project Manager, right-click Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup dialog boxGeneral tab, change theMaximum Number of

Iterations to 200.
3. Under Problem Types, retain the selections to solve for both Temperature and Flow.
4. Under Flow Regime, select Turbulent and clickOptions. In the Turbulent Flow Model

dialog box, retain the Zero Equation selection and clickOK.
5. Under Radiation Model, retain theOff selection to ignore heat transfer due to radiation.
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6. ClickOK
7. From the Filemenu, click Save.
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6 - Create Monitor Points
Before running the simulation, create thermal and flow monitors for block_1 and Grille_1.

Create a Thermal Monitor
1. In the History tree, expandModel > Solids > Al-Extruded.
2. Right-click block_1 and select Assign Monitor > Point.
3. In theMonitor Setup dialog box, enter Block_temperature for the Name.
4. Expand Thermal and select Temperature.
5. ClickOK.

Create a Flow Monitor
1. In the Project Manager under Thermal, right-clickGrille_1 and select Select Assign-

ment.
2. From the Icepakmenu, selectMonitor > Assign > Point.
3. In theMonitor Setup dialog box, enterGrille_speed for the Name.
4. Expand Flow and select Speed.
5. ClickOK.
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7 - Set Up and Run the Parametric Trials
Set Up the Parametric Trials
Define the parametric trials using the $zc variable assigned to the location of the fan component.

1. In the Project Manager, right-clickOptimetrics and select Add > Parametric.
2. In the Setup Sweep Analysis dialog box, click Add.
3. In the Add/Edit Sweep dialog box, select Single value.
4. Enter 0.1 meter for the Value and click Add.
5. Enter 0.165 meter for the Value and click Add.
6. ClickOK to close the Add/Edit Sweep dialog box.
7. Click the Table tab to display the two sweeps to be performed in the trials.

8. Click theOptions tab and enable Save Fields and Mesh. This will allow you to switch
between variation data when displaying post-processing objects.

9. ClickOK.
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Run the Parametric Trials
1. In the Project Manager, expandOptimetrics.
2. Right-click ParametricSetup1 and select Analyze.
3. In the Project Manager, expand Analysis.
4. Right-click Setup1 and select Residual to monitor the residuals as the trials run.

Note:When the simulation is complete, a message is displayed in theMes-
sages window stating "Parametric Analysis is done."

5. Click the Thermal Monitor and Flow Monitor tabs for the 0.1 meter design variation.
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6. Click the [...] button and select the 0.165 meter variation in the Set Design Variation dia-
log box.

7. Click the Residual, Thermal Monitor, and Flow Monitor tabs for the 0.165 meter design
variation.

Note: Use the navigation arrows on the image below to view each tab.

Note: On the Thermal Monitor tab, note the more efficient cooling by the fan in
the second variation's location.
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8 - Post-process the Results
The Ansys Electronics Desktop provides a number of ways to view and examine the solution res-
ults, including:

l Plane cut views
l Object face views
l Fields summary report

Create a Plane Cut
Create a plane cut plotting velocity using the Cut Plane toolkit. The current design variation is set
to the orignal fan offset location ($zc = 0.1 meter).

Create a Plane Cut
1. From the Icepakmenu, select Toolkit > Reporting > Cut_Plane.
2. Under Plane Location, select Z Plane through Center.
3. Select Show Vectors.
4. Click Create.
5. Click Exit.
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6. In the Project Manager, expand Field Overlays > CutPlane_1_Vector.
7. Right-click Velocity_Vectors1 and select Plot Visibility to hide the plane cut.

Create Object Field Overlays
Create a temperature plot on the wall. The current design variation is set to the original fan offset
location ($zc = 0.1 meter).

Plot Temperature on the Wall and Blocks
1. In the History tree, expandModel > Solids and FR-4.
2. Right-click Al-Extruded and select Select All.
3. Press Ctrl and selectwall_1 under FR-4.
4. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
5. In the Create Field Plot dialog box, retain the Temperature selection forQuantity.
6. Enable Plot on surface only.
7. Click Done.

8. In the Project Manager, expand Field Overlays > CutPlane_1_Vector.
9. Right-click Velocity_Vectors1 and select Plot Visibility to display both post-processing
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objects simultaneously.

Switch the Design Variation
After you've reviewed the plane cut and field plot results for the initial design variation, change
the design variation to review the results at the alternative fan location.

1. In the Project Manager, expandOptimetrics.
2. Right-click ParametricSetup1 and select View Analysis Result.
3. In the Post Analysis Display dialog box, select the 0.165meter variation and click

Apply.
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4. Click Close.

Create a Fields Summary Report
Create a fields summary report of object-specific solution data. Fields summary reports can
provide physical information from the solution about specific model boundary conditions or
objects.

1. From the Icepakmenu, select Fields > Create Fields Summary.
2. In the Fields Summary dialog box, for Design Variation, select $zc=0.1meter.
3. In the Setup Calculation dialog box, selectObject for Entity Type.
4. In the Entity list, select all of the Block objects.

Note: You can select multiple entities at once. When an entity is selected, select
it again to clear the selection.

5. In theQuantity list, select Temperature.
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6. From the Add drop-down list, select Add As Single Calculation.

7. In the Fields Summary dialog box, for Design Variation, select $zc=0.165.
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Note: Note the lower maximum and mean temperaures in the $zc=0.165meter
variation.
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9 - Summary
In this tutorial, you learned how to set up and solve multiple trials to optimize a parameter, spe-
cify a dynamically updating fan curve, create a new local coordinate system, and use separate
mesh regions to reduce mesh counts. The use of network blocks to model packages has been
demonstrated as well as how to specify contact resistance using side specifications of a block
object. You also learned how to generate a summary report for multiple solutions.
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